Thursday, May 5, 2011

Revit 2012 Type Catalog Bug

UPDATE - This has been fixed in Service Pack 1

Here’s a nasty little bug I found when editing families with type catalogs in 2012
Steps to reproduce:
Open a family that has a type catalog (W-Wide Flange is a good example) there is only one family type to start with in this family. Save the file. Now if you look at the family types all of them from the type catalog are in the family. At this point if you save (note that the ootb families are set to read only so you need to change this first), close and re-open the family the types go away and still left with one type. But if you change types to something besides W12x26 and save the file ALL of the types are saved in the family.
The development team has acknowledged this as a problem and said it requires a ‘code fix’ and can give no time frame of when it will be fixed.
My advice is to temporarily rename the txt file while editing your family so it doesn’t see it and ruin your day.
Support’s advice was that your library should be read only so this shouldn’t be a problem, that’s all good and fine for end users but when you’re editing the family it can become an issue.


  1. Good catch! This could be very problematic when a user loads a modified family, as they will likely be loading all the previously cataloged types now polluting the family.

    I recommend temporarily renaming the catalog files when modifying catalog based families, this will eliminate the need for read only files and ensure the catalog types are not loaded into the family file.

    Jeff S.

  2. Just so you know... code fix is not an admittance of a 'bug'. I'm continually amazed at how many names for a bug are out there. There's 'code fix', 'defect', 'application limitation', 'enhancement', etc. I got all these words in my reponses, but not one word about a 'bug'.

    I got a 'code fix' required response on reporting parameters with no guess to a timeline for a "fix". And the workaround was to not do what was needed to be done... huh? How can you even call that a workaround.

  3. In regards to: "How can you even call that a workaround...?" Well, that means 'the factory' means you should work around your work by not doing your work!!! LOL

  4. There is definitely sometype of bug. On some families it will strip out the default type(s) when there is an associated type catalog.

    These two different actions are hard to nail down what triggers it one way or the other.

  5. fyi they are guessing this will be fixed in SP1 but no guarantees.

  6. fyi this has been fixed in service pack 1

  7. Bit late, but SP1 sure fixed all the issues within this update.


Note: Only a member of this blog may post a comment.